Firefox 4.0b9pre: ecco il .deb sicuro

Ieri è stata rilasciata la build della beta 9 di firefox 4.0, la nuova versione del più popolare browser open. Questa versione introduce rilevanti novità rispetto alle precedenti ed è già riuscita a far parlare di sé, attirando come al solito un sacco di curiosi che vogliono provarlo prima della release ufficiale, e che ovviamente faranno a corsa per installarlo sulla propria GNU/Linux-box il prima possibile😀 . Come ho già fatto per il rilascio di ff3.6 ho deciso di fornire dei .deb, installabili quindi con un semplice doppio-click, o dpkg, che permettano a chiunque di testare la beta prima, e installare la versione stabile poi, senza intaccare l’installazione della versione default di firefox fornita dalla propria distro. Con questi .deb non dovrete rimuovere la versione stabile e potrete scegliere tranquillamente quale delle due avviare. L’installazione infatti viene effettuata interamente in /opt, ad eccezione di un eseguibile, diverso ovviamente da quello di ff stabile, che ho posizionato chiaramente in /usr/bin e vi permetterà quindi di avviare firefox anche da terminale in maniera semplicissima. I pacchetti inoltre forniscono un lanciatore personalizzato in modo da riconoscere in maniera inequivocabile la versione beta nel vostro menù. Dato che la build è inglese ho integrato il lancgpack italiano e predisposto lo script di avvio per lanciare l’applicazione già nella nostra lingua, senza che voi dobbiate fare alcun che! Per ora non ho molto da dire su questa versione, dato che ce l’ho da nemmeno un giorno (e soprattutto non ho potuto provarla né upparla ieri dato che la vodafone ha gentilmente deciso di troncarmi la connessione ieri sera…per l’ennesima volta…) ma non ho scritto questo articolo per darvi un’opinione, bensì per permettervi di farvene una vostra provando ff in prima persona! Non vi resta altro che scaricare, installare, provare e fare sapere a tutti cosa ne pensate:

download 32bit, 64bit.

Lo troverete alla voce Browser web Firefox-4.0b9pre del vostro menù Internet, ad esempio su gnome Applicazioni→Internet→Firefox-4.0b9pre. Per avviarlo da terminale semplicemente

firefox-4.0b9pre

ovviamente tutti i plugin che avete su ff li avrete anche qui, per evitare qualsiasi tipo di errore evitate di avviare contemporaneamente le due versioni, come al solito!

Fatemi sapere!

Aggiornamento: PerryGi mi ha fatto notare che nella nuova versione le impostazioni base prevedono il pulsante unico al posto della Barra dei menu, bene dato che abbiamo già delle impostazioni di ff nella nostra distro questo non appare in automatico, se lo volete basta andare in Visualizza→Barre degli strumenti→Barra dei menu e togliere la spunta. Per ripristinare la barra classica (molto meglio) fate click dx sopra il pulsante Minefield in alto a sx→barra dei menu!

Di nuovo buone prove!

Serve aiuto? LQH!

31 Responses to “Firefox 4.0b9pre: ecco il .deb sicuro”


  1. 1 burt 8 gennaio, 2011 alle 12:21 pm

    Wow ho appena scaricato provo e ti faccio sapere

  2. 2 streetcross 8 gennaio, 2011 alle 2:03 pm

    @burt grazie, per piacere dimmi che versione scarichi e se funziona, i pacchetti li ho testati su ubuntu 64 e lubuntu 32 ma non si sa mai😀

  3. 3 arlecchino92 8 gennaio, 2011 alle 2:24 pm

    Ho provato la versione a 32 bit su Ubuntu 10.10 e non da problemi. Presenta solo un’incompatibilità con un plugin che sulla beta 8 invece funzionava.

  4. 4 burt 8 gennaio, 2011 alle 2:29 pm

    Ho scaricato la versione ha 32 bit, perfettamente funzionante sù Maverick, lo trovata al posto giusto applicazioni internet, già in italiano con i miei preferiti, in questo momento scrivo da chromium semplicemente perche dopo aver installato sù firefox4 il maledetto plugin moonlight, firefox4 e tornato in inglese, niente di grave… comunque sia la prima impressione e velocità e interfaccia più comoda nell’uso.

  5. 5 Yattatux 8 gennaio, 2011 alle 6:10 pm

    Ciao Streetcross, ho scaricato la versione 64bit e la stò usando senza nessun problema su ubuntu 10.04.
    Tutto perfetto, la navigazione è ottima.
    Se ho tempo la provo su ubuntu 10.04 a 32 bit.
    Per ora ciao!

  6. 6 streetcross 8 gennaio, 2011 alle 6:19 pm

    @burt e yattatux grazie a tutti e due, sono contento di solito uppo per sbaglio i tentativi falliti ^_^ spero vi piaccia come idea questo deb, io odio rimpiazzre i programmi di sistema con altri che poi creano problemi con bug legati alle impostazioni della distro, come succedeva con firefox 3.0

  7. 7 Yattatux 8 gennaio, 2011 alle 6:23 pm

    Ottima idea. Anzi, ho notato che è uscita la nuova beta di Blender, se puoi creare un .deb dedicato non sarebbe male!😀
    Ciao!

  8. 8 streetcross 8 gennaio, 2011 alle 6:25 pm

    @arlecchino92 pardon non volevo mancare nei tuoi confronti ma ho approvato il commento dopo aver dato la prima risposta, quindi grazie anche a te. per il plugin forse necessita di una versione aggiornata adeguata, con i plugin talvolta capita di perdere la compatibilità, magari con l’uscita della versione stabile mettono a posto le cose

  9. 9 burt 8 gennaio, 2011 alle 7:06 pm

    Sono straassolutamente d’accordo nel non rimpiazzare i programmi di default, in questo modo posso testare in tutta tranquillità e se qualcosa non va, bam lancio il vecchio firefox e via verso nuove avventure.

  10. 10 streetcross 8 gennaio, 2011 alle 9:45 pm

    @burt anche perchè altrimenti non avrebbe senso scegliere una release fixed, se poi freghi la stabilità installando al posto delle versioni stabili i nuovi rilasci😀

  11. 11 fantasmino 8 gennaio, 2011 alle 11:20 pm

    Ciao streetcros, grazie del .deb, ottimo lavoro!
    Non sono uso a installare delle beta, ma questa volta mi hai tentato…
    Su maverick 32bit solo un problema di compatibilità con moonlight che impediva l’avvio della 4.0. L’ho disinstallato, tanto non mi ha mai funzionato, e ora scrivo dall beta 9. Molto bella e funzionale, anche più veloce, mi pare. A prima botta ottimi i cambiamenti, la barra schede spostabile in alto, l’incolla e vai, varie cose importate da chrome. Molte delle estensioni ovviamente ora non vanno e un piccolo baco preso al volo: la schermata dei componenti aggiuntivi ora si apre in una scheda, ma questo fa rimpicciolire al minimo la casella di ricerca della barra di google. Nel complesso mi piace molto, peccato non abbiano importato da chrome anche la larghezza fissa dei tab, è comoda quando ne vuoi chiudere alcuni in sequenza. Ora ci navigo un po’…🙂

  12. 12 PerryGi 9 gennaio, 2011 alle 2:11 pm

    Ciao Street,
    ho scaricato la 64bit su LMDE, l’installazione è andata bene,infatti ho in /opt firefox-4-0b9pre e in /usr/bin sia firefox che firefox-4-0b9pre.
    Solo una cosa che ritengo fastidiosa ma credo non ci si possa fare niente, al primo avvìo già mi carica tutti i settaggi di firefox, quindi me lo ritrovo già modificato come l’altra versione, l’ho rimessoio come “out of the box” ma rimango con l’incertezza di averlo realmente come tale.
    E poi non dovrebbe esserci il menù in alto a sinistra come su Windows?

  13. 13 PerryGi 9 gennaio, 2011 alle 2:12 pm

    Volevo dire: “rimango con l’incertezza di non averlo realmente come tale.”

  14. 14 obo 9 gennaio, 2011 alle 4:41 pm

    Ciao, non so se la cosa è voluta, ma da quando ho installato il tuo pacchetto (64bit) i server ftp a cui mi connetto (cliccando su Risose,Connetti al server…) si aprono all’interno di firefox e non in nautilus come dovrebbe essere.

    se qualcuno avesse lo stesso problema può risolvere aprendo il terminale, scrivendo gconf-editor, navigando in desktop -> gnome -> url-handles -> ftp e cambiando il valore in nautilus “%s”

  15. 15 streetcross 9 gennaio, 2011 alle 6:08 pm

    @fantasmino sì effettivamente c’è un forte ispirazione a chrome che però non mi piace molto, trovo utile l’incolla e vai di Opera ma al resto dell’interfaccia devo farmi l’abitudine😀

    @PerryGi chiaramente la cartella .mozilla è condivisa alla vecchia installazione, ti basta rinominarla per avere ff out-of-the-box, riguardo al menù non so di che parli perchè io Windows non lo uso ma posso garantirti che questa è la build ufficiale così come rilasciata senza alcuna modifica (anche perchè non si può)

    @obo onestamente non ne ho idea dato che non uso questa funzione di nautilus, grazie comunque per la dritta!

  16. 16 PerryGi 9 gennaio, 2011 alle 8:37 pm

    Parlo di questo:

    Oh, m’hai fatto avvia’ Windows per fattelo vede’!🙂

  17. 17 streetcross 9 gennaio, 2011 alle 8:49 pm

    @PerryGi beh minimo, non sia mai che devo comprarlo io😀
    Interessante, ma praticamente lì dentro si trova il menù della finestra (file modifica ecc) ? Ora mi informo e vedo se è prevista una cosa del genere pure sulla versione buona di Firefox (😀 )ma sinceramente spero di no, già mi ha -opinione personale chiaro- deluso un po’ la nuova interfaccia così come è, se mettono quella roba è la volta buona che non lo installo più! Comunque ti posso garantire che non ho fatto alcuna modifica alla build del sito mozilla, ripetendomi sottolineo che anche volendo non potrei perché la licenza non lo permette, e quindi evidentemente semmai è prevista una svolta del genere probabilmente arriverà con la versione stabile o più in la ancora😀 ora vedo che trovo

  18. 18 streetcross 9 gennaio, 2011 alle 9:10 pm

    @PerryGi ecco fatto leggi l’aggiornamento dell’articolo, sono un pollo, altro che cercare in internet mi son ricordato poi come togliere la la barra😀

  19. 19 PerryGi 9 gennaio, 2011 alle 9:35 pm

    OK, grazie.
    Non è ancora come su Windows, ma va gia bene.
    Mi piace il pulsante unico perché ho la fissa del risparmio dello spazio e così si evita di installare un plugin che tra l’altro su Minefield non funge (probabilmente proprio perché c’è il pulsantone), parlo di tiny menu.

  20. 20 streetcross 9 gennaio, 2011 alle 10:13 pm

    @PerryGi di niente figurati, comunque differenze minime tra la versione GNU/Linux e quella Windows ci son sempre state ma son tutte differenze di impostazioni base, nessuna reale, basta giocare con le configurazioni per trovare tutto quello che c’è… per i plugin invece è un discorso a parte, ovviamente bisogna aspettare che i plugin vengano aggiornati per la nuova versione una volta che sarà uscita la stabile😀

  21. 21 Yattatux 10 gennaio, 2011 alle 11:45 am

    Provato anche con Ubuntu 10.04 32bit, anche qui non noto problemi.😀 wow, non volevo dire niente sulla mancanza della barra e del pulsante unico perche’ pensavo che essendo una beta dovevano inserirla…😀
    con la barra classica e’ mooolto meglio!
    Ciao!

  22. 22 luimors 10 gennaio, 2011 alle 6:29 pm

    Installato su ubuntu 10.10 64bit, perfetto e ottimo

  23. 23 streetcross 11 gennaio, 2011 alle 10:45 am

    @Yattatux quoto sulla barra comunque io nemmeno mi ero posto il problema se non me lo facevano giustamente notare ^_^ comunque il pulsantone unico per me è troppo, già così faccio fatica ad abituarmici, stavolta con FF proprio non mi ci trovo:-/

    @luimors grazie del feedback!

  24. 24 FRANCESCO 13 gennaio, 2011 alle 3:14 am

    Grazie. Funziona anche su LMDE / Debian Sid potresti aggiungerlo. Noi ex ubuntiani riconvertiti Debian siamo sempre alla ricerca di pacchetti simili.
    ciao

  25. 25 streetcross 13 gennaio, 2011 alle 6:01 pm

    @FRANCESCO ma i miei pacchetti sono fatti per Debian e Ubuntu, anche io sono un Debianizzato😀

  26. 26 Nicola 14 gennaio, 2011 alle 5:19 pm

    ciao e grazie
    a me su mint i video mi mi vanno un po salti, tra l’altro l’avevo scaricata proprio sperando avesse un flash più aggiornato dato che avevo ancora quello della 3,6 beta (ma il deb della 3,6 stable esiste? ho torvato solo la beta che mi dava qualche problema negli streaming) ora ho risolto aggiornando il flash plugin direttamente dal sito di adobe, comunque volevo se è possibile 2 informazioni

    1) come si rimuove le beta di ff4? nei pacchetti syanptic non la trovo e da terminale mi dice impossibile trovare firefox 4.0 ecc

    2) se farai anche il deb di firefox4 stable, i vari plugin tipo flash, o gli accorgimenti per la sicurezza saranno auto-aggiornanti?

  27. 27 streetcross 14 gennaio, 2011 alle 5:56 pm

    @Nicola cerca firefox su synaptic e vedi che lo trovi, il pacchetto si chiama esattamente come il deb, ovvero firefox-4.0b9pre

    mint è ubuntu, che versione? probabilmente non l’ultima ad ogni modo i plugin vengono gestiti dal proprio sistema operativo e non da firefox, non vado a modificare tale funziona per prima cosa per motivi di licenza, secondo perchè ai più creerebbe problemi😀

    firefox 3.6 stabile è la versione default su ubuntu 10.10 e quindi mint, trovi i pacchetti nei repo

  28. 28 Nicola 14 gennaio, 2011 alle 6:42 pm

    @ streetcross
    nei pacchetti non l’ho proprio visto, però da terminale dandogli firefox-4.0b9pre ha funzionato, grazie! io avevo provato con il nome per intero e poi solo con firefox 4.0
    per il resto, allora io ho mint 6, è un po vecchiotta ma purtroppo le versioni successive mi davano qualche problema di hardwere, sopratutto con il monitor, quindi ho tenuto la 6 che nei repo aveva firefox 3.0.
    Ho preso sempre dal tuo blog la 3,6 che sino ad oggi mi dava problemi con youtube e simili, ma ora sembrerebbe tutto ok avendo aggiornato all’ultima versione di flash, al prossimo deb allora, ciao

  29. 29 streetcross 14 gennaio, 2011 alle 10:44 pm

    @Nicola ok, appena ci sarà la versione stabile sai dove cercarla😀 alla prossima!


  1. 1 Installare Firefox 4.0 beta 9 pre Trackback su 8 gennaio, 2011 alle 3:49 pm
  2. 2 Firefox 4.0b10pre: ecco il .deb sicuro « Il Blog di Streetcross Trackback su 13 gennaio, 2011 alle 6:29 pm

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...




Serve aiuto? LQH!
gennaio: 2011
L M M G V S D
« Dic   Nov »
 12
3456789
10111213141516
17181920212223
24252627282930
31  

Blog Stats

  • 419,021 hits

Più cliccati

  • Nessuna
Planet LQH
Planet di ubuntu-it


Smilla Magazine
iwinuxfeed.altervista.org

RSS Feed sconosciuto

  • Si è verificato un errore; probabilmente il feed non è attivo. Riprovare più tardi.

%d blogger cliccano Mi Piace per questo: