ASUS WL-167G su GNU/Linux

wl-167g

ATTENZIONE LA GUIDA VALE SOLO PER I KERNEL FINO AL 2.26, I SUCCESSIVI CONTENGONO LA NUOVA VERSIONE DEI DRIVER PERFETTAMENTE FUNZIONANTI. PER CHI AVESSI ANCORA VECCHI KERNEL, VEDI DEBIAN STABLE/TESTING CONSIGLIO VIVAMENTE LA COMPILAZIONE DI UN KERNEL RECENTE, È MOLTO MEGLIO. SE NON VOLETE FARLO ALLORA SEGUITE PURE LA GUIDA, MA FATE ATTENZIONE, IL SUPPORTO AI DRIVER LEGACY È SCADUTO!

Volevo scrivere l’ennesimo articolo su questa famosa pennetta wi-fi, infatti nonostante in rete si trovi di tutto e di più, spesso le informazioni che si riescono ad ottenere sono erronee o obsolete. Per prima cosa una info fondamentale, col kernel di Intrepid Ibex la pennetta viene riconosciuta perfettamente e può essere perfettamente impostato con network-manager 0.7, ovviamente presente all’installazione di Intrepid. Tutto il resto che trovate scritto non vi serve, non vi serve wicd, non vi serve blacklistare moduli ecc… Per tutti gli altri (GNU/Linux – Intrepid Ibex) invece bisogna precisare che sì c’è il modulo nel kernel che teoricamente riconosce la vostra chiavetta, infatti per vederla la vede, il problema è che non si connette, ma questo modulo è inutile ed inutilizzabile. Seguirà ora una rapida guida su come utilizzare la nostra pennetta su una distro come Debian, Slackware o altro, gli strumenti da utilizzare sono infatti facilmente reperibili per tutte le distro (al 90% precompilati). N.B: La guida è valida per tutte le altre pennette con chipset rt73.Per prima cosa procuriamoci i driver open, molto meglio di quelli forniti dal produttore. Scaricateli da qui nella loro ultima versione disponibile. Rimuoviamo quindi il modulo presente nel kernel dando da super utente

rmmod rt73usb

blacklistiamo tutti questi moduli

blacklist rt73usb
blacklist rt2570
blacklist rt2x00lib
blacklist rt2500usb

inserendoli ovviamente in /etc/modprobe.d/blacklist dopo avere aperto il file con un editor di testo. Scompattiamo l’archivio coi driver e col comando cd spostiamoci all’interno della cartella Module, compiliamo ed installiamo (sempre da root):

make

strip -s rt73.ko

make install

aggiungiamo al file /etc/modules il nuovo modulo, basta aprire il file con un editor di testo ed inserire alla fine

rt73

Salviamo e riavviamo. Dovremmo ora vedere con ifconfig la nostra chiave, generalmente chiamata wifi0. Per utilizzare la nostra connessione utilizziamo questi semplici strumenti, Wicd (eventualmente a sostituire network manager) e RutilT. Questi pacchetti sono reperibili per debian tramite repo, mentre per slackware si trovano precompilati il primo qui, il secondo dovrebbe esserci nei repo ufficiali. Rutilt serve semplicemente a configurare le chiavette ralink, wicd si connette grazie a queste impostazioni in maniera davvero semplice, l’importante è ad ogni accensione di fare lo “scan” delle reti disponibili, infatti se si seleziona quella vecchia, cioè vista e utilizzata in precedenza, non ci si riuscirà a connettere, anche se la rete è la stessa. Che dire buona navigazione😉 .

18 Responses to “ASUS WL-167G su GNU/Linux”


  1. 1 Daniela 20 febbraio, 2009 alle 8:44 pm

    Ho provato a configurare la pennetta su un ibook con lenny. Ho seguito scrupolosamente le tue istruzioni. La chiavetta è installata e attiva, tenta disperatamente di connettersi all’access point, ma non riesce. L’access point funziona, perché l’altro computer si connette tranquillamente. Il messaggio di errore che mi dà è
    No DHCPOFFERS received.
    No working leases in persistent database – sleeping.
    ifconfig la vede come wlan0
    Mi puoi dare qualche dritta?
    Grazie

  2. 2 streetcross 21 febbraio, 2009 alle 9:43 am

    @Daniela con cosa cerchi di connetterti? Io su Sid ultimamente ho avuto dei problemi con wicd (penso legati agli aggiornamenti) ed ho risolto disinstallando wicd (basta anche non farlo avviare volendo) ed utilizzando solamente rutilt, funziona benissimo

  3. 3 Daniela 21 febbraio, 2009 alle 8:34 pm

    In realtà io avevo provato cnetwork manager.

    ifconfig la vede come wlan0 e legge il suo mac

    Ho scaricato ruitilt, ci sono tante cose da impostare! oppore basta creare un nuovo profilo?
    Ho provato a lambiccare: stesso risultato: la chiavetta manda in giro i pacchetti, vede gli access point disponibili, ma non riceve
    Non è che centra il fatto che il computer sia un vecchio mac ibook g3? Il lenny comunque è aggiornato.
    Ho un altro dubbio: perché mettere quei pacchetti in blacklist?

    Ancora grazie
    Daniela

  4. 4 streetcross 22 febbraio, 2009 alle 1:50 pm

    @Daniela basta creare un nuovo profilo è semplicissimo. I moduli vanno blacklistati perchè vanno in conflitto con quelli che poi installi😉

  5. 5 Daniela 4 marzo, 2009 alle 5:34 pm

    Grazie per le indicazioni. Ho ripreso a lavorare sulla chiavetta dopo un po’ e ho bisogno ancora di aiuto. Ho installato Rutilt, ho fatto il profilo, ora vedo gli access point che ci sono in giro, anche quelli dei miei vicini di casa. Mi dà attivo in entrata e in uscita, ma non si connette. Anche l’acces point non vede la scheda connessa.
    Da quello che scrivi debbo aggiungere wicd: serve per agganciare? Ma se vado per installarlo non lo trovo. E’ in qualche repository particolare?
    Ho cercato qualcosa ma non ho capito bene
    grazie molte. Andrà in conflitto con network mamager che in realtà non riesce a fare il suo lavoro, perchè non connette nulla anche se ho fatto il profilo.
    daniela

  6. 6 streetcross 7 marzo, 2009 alle 10:22 am

    @Daniela no adesso wicd non ti serve, a me ha dato solo che conflitti, ho provato con network manager 0.7 ma purtroppo non è ancora perfettamente compatibile col modulo rt73 e non permette connessioni protette tramite WPA, l’unico metodo per me è utilizzare rutilt, sei sicura di averlo impostato bene?

  7. 7 Daniela 7 marzo, 2009 alle 11:05 pm

    ho fatto un passo avanti: ora mi vede gli access point, posso sceglierli. Nella prima scheda c’è tutto tranne il campo col segnale: in pratica vede l’access point, riceve, ma poi cosa non va? Cosa manca?

  8. 8 streetcross 8 marzo, 2009 alle 5:31 pm

    @Daniela non saprei, le reti sono protette da wpa? hai installato wpa_suppllicant?

  9. 9 Flagello 14 marzo, 2009 alle 2:45 pm

    Ciao a tutti. Ho UBUNTU 8.10 e la chiavetta WL-167 Asus con chipset ralink r73. Il sistema vede gli access point e vede e relativi dati tramite “iwlist scan” con “iwconfig” al termine della procedura sopra la chiavetta agganciata alla mia rete di casa e iwconfig la da R73 e non più WLAN (come con i driver originali) ma non mi si connette, non fa l’autenticazione WPA.
    RUTILT da me ha solo due modalità WEP o nessuna autenticazione. Come devo fare per far andare questa benedetta antenna? Ho letto centinaia di HOW-TO e guide, provato driver su driver e diversi sw per la gestione delle reti ma il risultato è sempre lo stesso, vede ma non si connette.
    Qualcuno può aiutarmi?

  10. 10 flagello 14 marzo, 2009 alle 2:47 pm

    Ciao a tutti. Ho UBUNTU 8.10 e la chiavetta WL-167 Asus con chipset ralink r73. Il sistema vede gli access point e vede e relativi dati tramite “iwlist scan” con “iwconfig” la chiavetta agganciata alla mia rete di casa WPA e iwconfig la da R73 e non più WLAN (come con i driver originali) ma non mi si connette, non fa l’autenticazione WPA. Ho provato anche altre vie: wicd (non vede niente), RUTILT (vede la rete ma mi fa scegliere solo tra nessuna autenticazione o WEP). Qualche aiuto/dritta? Grazie

  11. 11 Daniela 14 marzo, 2009 alle 4:05 pm

    mi sono rassegnata a provare su un windows: stesso identico problema, vede le reti disponibili, prende il profilo, ma non si aggancia.con relativo messagggio “problema sconosciuto” ne deduco che forse è difettosa la chiavetta. E io che mi sono scervellata per un mese!

  12. 12 flagello 15 marzo, 2009 alle 8:50 am

    Ciao Daniela, su windows la chiavetta è perfettamente funzionante, ne ho tre in casa su tre diversi pc. Ho avuto problemi con il sw asus contenuto nel cd. Come risolvere? Cancella il sw Asus, disinstalla tutto della chiavetta e rimuovi l’hardware dalle periferiche. Poi riavvia, inserisci la chiavetta, ti trova nuovo hw, fai fare la ricerca dei driver nel cd dell’antenna e installali senza usare il tool originale.
    Ora XP ti vede le reti, scegli la tua di casa e inserisci la chiave WPA e WEP che hai sul router (senza spazi) ecco ora sei connessa. Se così non va allora è un problema hw. Magari fosse così semplice su Linux.

  13. 13 streetcross 18 marzo, 2009 alle 1:56 pm

    @Daniel allora il tuo problema è nell’access point e non in ubuntu, la chiavetta dubito abbia problemi ma puoi provare con un’altra!

    @flagello non capisco perchè ti sei complicato, su ubuntu è più facile su che xp. infatti su xp devi installare i driver mentre su ubuntu 8.10 inserisci la chiavetta e funziona, in questo momento sto proprio scrivendo dal mio ubuntu con la rt73…non dovevi far nulla, bastava leggere quello che ho scritto nella guida invece di dire che “linux” (ps un kernel…) non funziona

  14. 14 flagello 18 marzo, 2009 alle 5:25 pm

    ho provato da un amico su kubunto e la chiavetta va benissimo.
    io sto virtualizzando ubuntu da vmware senza passare per la scheda di rete virtuale in modalità bridge ma direttamente cercando una connessione wifi dentro la macchina virtuale.
    Molto probabilmente il mio problema è un conflito sulla macchina virtuale. Appena installo il SO testo e posto il risultato.
    Confermo: dal mio amico su kubuntu 8.10 ho inserito la chiavetta e automaticamente si è connesso, come con windows xp.

  15. 15 streetcross 19 marzo, 2009 alle 1:53 pm

    @flagello i driver sono presenti sia in ubuntu che kubuntu dato che sono lo stesso medesimo sistema operativo, io l’ho utilizzata anche in virtuale e funziona…comunque non è vero che su xp la inserisci e funziona, devi installare i driver e tra l’altro da anche problemi con la wpa a volte…

  16. 16 flagello 19 marzo, 2009 alle 5:34 pm

    Installato ubuntu 8.10 inserito la chiavetta e tutto ok, chiede password e via che va liscio, come windows (dopo aver installato i driver con cd allegato alla chiavetta wifi).
    su vmware internet va via bridge con schede di rete o wifi del sistema operativo che ha dietro. Se togli le connessioni di rete e provi a crearne una direttamente da ubuntu virtualizzato continua a chiedere la chiave wpa e non si connette anche se con iwconfig risulta agganciato all’access point. Comunque il problema non si pone dal reale sistema operativo va a meraviglia, con la 8.10 non importa fare nulla, tutte le cose che si leggono in giro nei forum sono inutili complicazioni.
    Buona navigazione a tutti.

  17. 17 Magsas 14 giugno, 2009 alle 7:56 am

    Ciao streetcross,
    per prima cosa ti vorrei segnalare che il link ai driver non funziona più. Io li ho scaricati da sourceforge.
    Poi, ho provato a seguire la guida sulla mia Debian squeeze (kernel 2.6.26-2-686), ho eseguito tutti i passi, ma dando ifconfig non mi vede nessuna wlan. Mi puoi suggerire qualcosa? Grazie. Ciao

  18. 18 streetcross 14 giugno, 2009 alle 2:57 pm

    @Magsas sì hai ragione il link non funziona perchè i driver sono ora del tutto non supportati. i nuovi driver integrati nel kernel funzionano senza alcuna modifica con network manager 0.7, ti consiglio vivamente di compilare un kernel più recente, sembra sciocco ma è più pratico, fidati mi hanno fatto dannare molto questi legacy.


Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...




Serve aiuto? LQH!
novembre: 2008
L M M G V S D
« Ott   Dic »
 12
3456789
10111213141516
17181920212223
24252627282930

Blog Stats

  • 419,021 hits

Più cliccati

  • Nessuna
Planet LQH
Planet di ubuntu-it


Smilla Magazine
iwinuxfeed.altervista.org

RSS Feed sconosciuto

  • Si è verificato un errore; probabilmente il feed non è attivo. Riprovare più tardi.

%d blogger cliccano Mi Piace per questo: